Audi Q5 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello everyone, first sorry for bad English smile
I want to ask for some help, if someone faced same problem.
Car is Q5 2010 year CGLB motor.
After swap Instruments cluster with facelift, didnt have coolant temperature at all. Something happen and cluster read it 0.00 degree.
What i do:
Test with 2-3 clusters, same thing - not cluster problem. After return to prefacelift cluster coolant temp is shown correctly.
Test with every possible index version facelift cluster - 0 coolant temp.
Test with facelift gateway 8R - 0 coolant temp
Run cluster at table, show -48, they see that coolant info missing and as usual show -48/-50
Update every possible module to latest version - 0 coolant temp.
Now the only thing maybe is ECU. Collant temp sensor is simple wired. Just go to ECU and ECU send it to CAN wire. Maybe something mismatch about CAN signals and I want to flash it with different version again for CGLB motor.
My ECU is 03L 906 018 ML HW:21 - maybe too old, but possible latest version for them is 9977.
Test cluster in A4 car where ECU is with flash version 9978 and show temp.
For my engine ECU what i found in internet is 03L 906 018MQ and ML. MQ have 9978 flash file but its HW:25 not 21.
I flash ECU with odis to MQ version but cannot be coded at all and again not show coolant temperature.
I wonder if anyone know how to be fixed to use facelift cluster.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I swap it because is SQ5 cluster.
I didn't understand that with temperature display
its one of most important thing to have coolant temperature gauge, on every car.
 

·
Registered
Audi SQ5 2015
Joined
·
1,959 Posts
Maybe you can fix it by changing a setting via VCDS?
 

·
Registered
Joined
·
2 Posts
Non posso impostarlo con VCDS credo. Non avevo opzioni del genere, nessun adattamento forse...
hai trovato la soluzione al tuo problema? da quello che ho potuto scoprire il problema è chi non ha di serie il sistema hill hold. Ho il motore caha q5 8r del 2009 con il pulsante di tenuta della collina e ho montato un tacho sq5 del 2014 e la mia temperatura funziona alla grande. un mio amico con il tuo stesso motore e anno ma senza pulsante hill hold ha montato il tacho sq5 del 2013 e anche lui non alza la temperatura
Speedometer Odometer Car Trip computer Tachometer
 
1 - 9 of 9 Posts
Top