Audi Q5 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all. I have a 2016 Q5 & the discs were getting worn with a wobble at the front left when braking.
I purchased a full set of Mtec 2 piece front, single rear C hook discs with Mintex pads.
All fitted perfectly clean and tidy.
Bedded in but now when coming off slip roads and hitting the brakes the left violently shakes unless I stamp on the pedal to make more contact.
Normal braking I get like a grab,grab,grab effect which I assume is the c hook on the disc but maybe I'm talking out of my arse.
I sought assistance and the only thing we could assume was a warped disc after reading some Mtec issues on the Web so I bought another disc to return the other under warranty.
I have now changed the disc and the problem still exists.
I'm at a loss as to whether it's the caliper, hub, abs sensor or something else. Caliper Is 4 pot brembo standard.

Has anyone else had this issue and resolved it before I end up spending a fortune on parts I don't need

Thankyou very much. Dave.

Sent from my SM-G998B using Tapatalk
 

·
Registered
Audi SQ5 2015
Joined
·
1,897 Posts
Maybe try bleeding (and then top up) the brake line, to make sure there is no air bubbles? When you changed to the the latest brake disc did you also change the pads again?
 

·
Still Game
Joined
·
4,674 Posts
It is possible that disc is not seating properly on the hub. It only takes a small piece of trapped grit. would use a dial gage. Spin the hub to check for disc warp / misalignment
 
1 - 3 of 3 Posts
Top